How to update to the latest PHP versions for WordPress

Some of our plugins and themes do only work with the latest PHP version. In most cases it’s okay when at least PHP in version 5.3.0 is running on your webserver. According to Wikipedia the support of version 5.2 has reached “End-of-life” in 2010. Therefore you should consider to update.

Unfortunately some of you will not have access to the server and the knowledge to update PHP. But, the good thing is, that PHP 5.3.0 is out since 2009 and it’s well supported by most webhosting providers.

So please ask your website provider how you can switch to a new version. A Google search will help in most cases. For example: If you’re on a HostGator webserver you can follow this simple steps without contacting the customer support: How to use PHP 5.3 with HostGator.

Here are some other providers that offer support on their websites: